mp3enc: remove mp3_write_packet(), use ff_raw_write_packet() instead
[libav.git] / LICENSE
CommitLineData
4656c375
DB
1FFmpeg:
2-------
3
aae9c405 4Most files in FFmpeg are under the GNU Lesser General Public License version 2.1
ecc1330a
DB
5or later (LGPL v2.1+). Read the file COPYING.LGPLv2.1 for details. Some other
6files have MIT/X11/BSD-style licenses. In combination the LGPL v2.1+ applies to
aae9c405
DB
7FFmpeg.
8
9Some optional parts of FFmpeg are licensed under the GNU General Public License
ecc1330a 10version 2 or later (GPL v2+). See the file COPYING.GPLv2 for details. None of
aae9c405
DB
11these parts are used by default, you have to explicitly pass --enable-gpl to
12configure to activate them. In this case, FFmpeg's license changes to GPL v2+.
13
14Specifically, the GPL parts of FFmpeg are
15
16- libpostproc
aae9c405 17- optional x86 optimizations in the files
aae9c405 18 libavcodec/x86/idct_mmx.c
aae9c405
DB
19- the X11 grabber in libavdevice/x11grab.c
20
4656c375
DB
21There are a handful of files under other licensing terms, namely:
22
23* The files libavcodec/jfdctfst.c, libavcodec/jfdctint.c, libavcodec/jrevdct.c
24 are taken from libjpeg, see the top of the files for licensing details.
25
9cad0e4e
DB
26Should you, for whatever reason, prefer to use version 3 of the (L)GPL, then
27the configure parameter --enable-version3 will activate this licensing option
28for you. Read the file COPYING.LGPLv3 or, if you have enabled GPL parts,
29COPYING.GPLv3 to learn the exact legal terms that apply in this case.
30
4656c375
DB
31
32external libraries:
33-------------------
34
aae9c405
DB
35Some external libraries, e.g. libx264, are under GPL and can be used in
36conjunction with FFmpeg. They require --enable-gpl to be passed to configure
37as well.
38
0b175caa
DB
39The OpenCORE external libraries are under the Apache License 2.0. That license
40is incompatible with the LGPL v2.1 and the GPL v2, but not with version 3 of
41those licenses. So to combine the OpenCORE libraries with FFmpeg, the license
42version needs to be upgraded by passing --enable-version3 to configure.
43
fc1206a4
DB
44The nonfree external library libfaac can be hooked up in FFmpeg. You need to
45pass --enable-nonfree to configure to enable it. Employ this option with care
46as FFmpeg then becomes nonfree and unredistributable.