Print static vhook warning for Cygwin and MinGW
[libav.git] / configure
index 5a5b8e1..119320e 100755 (executable)
--- a/configure
+++ b/configure
@@ -1671,10 +1671,10 @@ test "$vhook" = "default" && vhook="$dlopen"
 
 enabled_any vhook liba52bin libfaadbin ffserver && add_extralibs $ldl
 
-if test "$targetos" = cygwin && enabled_all static vhook ; then
+if test "$targetos" = cygwin -o "$targetos" = mingw32 && enabled_all static vhook ; then
     vhook="no"
     echo
-    echo "At the moment vhooks don't work on Cygwin static builds."
+    echo "At the moment vhooks don't work on Cygwin or MinGW static builds."
     echo "Patches welcome."
     echo
 fi