Revert "Fix libx264 configure check to use pkg-config if available."
authorMåns Rullgård <mans@mansr.com>
Mon, 19 Apr 2010 19:37:31 +0000 (19:37 +0000)
committerMåns Rullgård <mans@mansr.com>
Mon, 19 Apr 2010 19:37:31 +0000 (19:37 +0000)
There are problems using pkg-config, and a better solution is being
worked on.

Originally committed as revision 22914 to svn://svn.ffmpeg.org/ffmpeg/trunk

configure

index da67718..02ea987 100755 (executable)
--- a/configure
+++ b/configure
@@ -2612,7 +2612,7 @@ enabled libschroedinger && add_cflags $(pkg-config --cflags schroedinger-1.0) &&
 enabled libspeex   && require  libspeex speex/speex.h speex_decoder_init -lspeex
 enabled libtheora  && require  libtheora theora/theoraenc.h th_info_init -ltheoraenc -ltheoradec -logg
 enabled libvorbis  && require  libvorbis vorbis/vorbisenc.h vorbis_info_init -lvorbisenc -lvorbis -logg
 enabled libspeex   && require  libspeex speex/speex.h speex_decoder_init -lspeex
 enabled libtheora  && require  libtheora theora/theoraenc.h th_info_init -ltheoraenc -ltheoradec -logg
 enabled libvorbis  && require  libvorbis vorbis/vorbisenc.h vorbis_info_init -lvorbisenc -lvorbis -logg
-enabled libx264    && require  libx264 x264.h x264_encoder_encode $(pkg-config --libs x264 2> /dev/null) -lx264 -lm &&
+enabled libx264    && require  libx264 x264.h x264_encoder_encode -lx264 -lm &&
                       { check_cpp_condition x264.h "X264_BUILD >= 83" ||
                         die "ERROR: libx264 version must be >= 0.83."; }
 enabled libxvid    && require  libxvid xvid.h xvid_global -lxvidcore
                       { check_cpp_condition x264.h "X264_BUILD >= 83" ||
                         die "ERROR: libx264 version must be >= 0.83."; }
 enabled libxvid    && require  libxvid xvid.h xvid_global -lxvidcore