configure: require --arch and --target-os when cross-compiling