Add configure option to upgrade (L)GPL to version 3.