works with old gcc versions too