w32pthreads: always use Vista+ API, drop XP support