try to stop people blindly using --cross-compile